个性化阅读
专注于IT技术分析

Ruby on Rails捆绑器bundler用法

在Rails中, 捆绑程序通过跟踪和安装所需的合适的gem来为Ruby项目提供恒定的环境。它可以在整个生命周期内跨许多机器系统地, 重复地管理应用程序的依赖关系。

要使用捆绑程序, 你需要安装它。

gem install bundler

Gem捆扎机捆绑你的应用所基于的所有合适的Gem。捆绑Rails和其他依赖项会将子弹大小增加几兆字节。增大子弹头大小对于简化依赖关系管理是一个值得权衡的选择, 同时也可以灵活使用所需的任何版本的Rails。

要不安装一组Gem, 请使用BUNDLE_WITHOUT配置变量。

捆绑器版本

不同版本的捆绑软件具有不同的错误和行为。捆绑软件版本通常需要大量的验证和确认, 并且很少发布。它需要最大的稳定性, 避免Bundler更改时的弃用和通知周期。


捆绑器版本问题

不同的捆绑程序版本具有不同的错误。

捆绑器1.13.6

如果你使用的是较旧版本的捆绑程序, 则可以在Gemfile.lock文件中使用Ruby版本。根据你Gemfile中的Ruby声明, 它无效。

你将收到以下错误:

Your Ruby version is 2.2.5, but your Gemfile specified 2.3.1

你需要升级到最新的捆绑软件。


捆绑器1.13.1

你将收到以下错误:

Bundler Output: requires_greater_than_equal_ruby_two_two-0.1.0 requires ruby version >= 2.2.2, which 
is incompatible with the current version, ruby 2.1.7p400

你需要升级Ruby版本以与gem中指定的最低Ruby版本兼容。


捆绑器1.11.2

有时, 你的应用程序可能与当前没有有效gemspec的gem一起运行。


赞(0) 打赏
未经允许不得转载:srcmini » Ruby on Rails捆绑器bundler用法
分享到: 更多 (0)

评论 抢沙发

评论前必须登录!

 

觉得文章有用就打赏一下文章作者

微信扫一扫打赏